English (United Kingdom)
Jms Multi Site, formerly joomla multisite.
Create, share multiple joomla sites in few clicks !
Welcome, Guest
Please Login or Register.    Lost Password?
Go to bottomPage: 1
TOPIC: Slave won't connect
#10994
Slave won't connect 5 Years ago Karma: 0
Two sites that already exist on separate servers. I want to share articles from master to slave. I installed both multisite and article sharing on both. The master has a folder with the slave site name in the root with config_multisites.php created

Do I need to create the same thing in reverse on the slave? it does not like the path to the master? here is the hello world readout.

hello world script
The current path is "/var/www/vhosts/sweathelp.org/httpdocs"
Symbolic Link is PRESENT on Linux platform

What would I put in the site details on the slave? I get this error

The deployed directory [/var/www/vhosts/sweathelp.org/httpdocs] does not exists.
designhow
Fresh Boarder
Posts: 1
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#11001
Re: Slave won't connect 4 Years, 12 Months ago Karma: 53
If your websites are on different machine (server), this is normal that the directory present in one server does not exists on the other server.

If you just want to have the "article sharing" reading the other server, you just have to create a kind of "fake" slave site that defined the correct DB connection of the other machine. So that the slave site in the server 1 will be setup with the DB connection of the other website on server 2.

On server 1:
- Create a slave that identify the website 2 present on the server 2 with DB 2

On Server 2
- Create a slave that identify the website 1 present on the server 1 with DB 1
edwin2win
Moderator
Posts: 5292
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
get the latest posts directly to your desktop
2Win, Multisite(s) are trademarks of Edwin2Win.
Joomla